macOS notes

Some usefull tricks i've found over the years.
Just collected here to be usefull for others and myself.

'Genie FX' is gone in macOS High Sierra?!

Have you ever pushed SHIFT while min/maximizing a window? What a useless feature, but still some kind of fun. Only used by Steve Jobs in a Keynote while presenting Expose (youtube) and now: it's gone... as long you enable it again with: defaults write com.apple.dock slow-motion-allowed -bool YES && killall Dock

Show hidden files in Finder

run this in terminal and restart Finder:
$ defaults write com.apple.finder AppleShowAllFiles YES

Install from any source

Disable Gatekeeper to install homebrew software with this terminal command:
$ sudo spctl --master-disable

Add spacer to Dock

in Terminal type:
$ defaults write com.apple.dock persistent-apps -array-add '{tile-data={}; tile-type="spacer-tile";}'
then:$ killall Dock

Disable local backups

Is that hidden .mobileBackups eating up a lot disk space? Disable mobile local backups with:
$ sudo tmutil disablelocal

Disable Dashboard

$ defaults write com.apple.dashboard mcx-disabled -boolean YES && killall Dock

Display connected USB devices

$ ioreg -p IOUSB

Watch file changes and run script(s)

$ brew install fswatch
$ fswatch -o ~/x.txt | xargs -I % sh -c './x.sh && ./x.sh'

release disk space used by local backups

Strange... opening the "Storage administration" windows (Cmd-U) in "System Information" released the local time machine snapshots making the space available.